Install directed graphs 51/41951/1
authorTimoney, Dan (dt5972) <dt5972@att.com>
Tue, 10 Apr 2018 15:46:29 +0000 (11:46 -0400)
committerTimoney, Dan (dt5972) <dt5972@att.com>
Tue, 10 Apr 2018 15:46:29 +0000 (11:46 -0400)
Added execution to maven-dependency-plugin in odlsli/pom.xml
to install directed graphs.

Change-Id: I5bb9a01407d541be6e876f560faf1596fdbc4510
Issue-ID: CCSDK-237
Signed-off-by: Timoney, Dan (dt5972) <dt5972@att.com>
odlsli/pom.xml

index 3c306de..8edfebb 100644 (file)
                             <excludeTransitive>true</excludeTransitive>
                         </configuration>
                     </execution>
+                    <execution>
+                        <id>unpack dgs</id>
+                        <phase>generate-sources</phase>
+                        <goals>
+                        <goal>unpack</goal>
+                        </goals>
+                        <configuration>
+                            <outputDirectory>${basedir}/target/docker-stage/opt/onap/ccsdk</outputDirectory>
+                            <artifactItems>
+                                <artifactItem>
+                                    <groupId>${project.groupId}</groupId>
+                                    <artifactId>platform-logic-installer</artifactId>
+                                    <version>${project.version}</version>
+                                    <type>zip</type>
+                                </artifactItem>
+                            </artifactItems>
+                        </configuration>
+                    </execution>
                 </executions>
             </plugin>
             <plugin>
                 <version>1.5.0</version>
                 <executions>
 
-<!--                     <execution>
-                        <id>Get features</id>
-                        <phase>generate-sources</phase>
-                        <goals>
-                            <goal>exec</goal>
-                        </goals>
-                        <configuration>
-                            <executable>/bin/bash</executable>
-                            <environmentVariables>
-                                <SDNC_CORE_VERSION>${ccsdk.sli.core.version}</SDNC_CORE_VERSION>
-                                <SDNC_ADAPTORS_VERSION>${ccsdk.sli.adaptors.version}</SDNC_ADAPTORS_VERSION>
-                                <SDNC_NORTHBOUND_VERSION>${ccsdk.sli.northbound.version}</SDNC_NORTHBOUND_VERSION>
-                                <SDNC_PLUGINS_VERSION>${ccsdk.sli.plugins.version}</SDNC_PLUGINS_VERSION>
-                                <SDNC_OAM_VERSION>${project.version}</SDNC_OAM_VERSION>
-                            </environmentVariables>
-                            <arguments>
-                                <argument>${basedir}/src/main/scripts/installZips.sh</argument>
-                                <argument>${basedir}/target/docker-stage/opt/onap/ccsdk</argument>
-                            </arguments>
-                        </configuration>
-                    </execution> -->
-
                     <execution>
                         <id>change shell permissions</id>
                         <phase>process-sources</phase>

© 2017 ONAP. Copyright © The Linux Foundation ®. All Rights Reserved.
The Linux Foundation has registered trademarks and uses trademarks.
For a list of trademarks of The Linux Foundation, please see our Trademark Usage page.
Linux is a registered trademark of Linus Torvalds.
Privacy Policy and Terms of Use