Update version to 1.13.5
[sdc.git] / openecomp-be / api / openecomp-sdc-rest-webapp / application-config-rest / application-config-rest-services / pom.xml
index d261f46..dab2620 100644 (file)
@@ -9,13 +9,9 @@
   <parent>
     <groupId>org.openecomp.sdc</groupId>
     <artifactId>application-config-rest</artifactId>
-    <version>1.7.0-SNAPSHOT</version>
+    <version>1.13.5-SNAPSHOT</version>
   </parent>
 
-  <properties>
-    <jersey-common.version>2.22.2</jersey-common.version>
-  </properties>
-
   <dependencies>
 
     <dependency>
       <version>${swagger.version}</version>
     </dependency>
     <dependency>
-      <groupId>javax.ws.rs</groupId>
-      <artifactId>javax.ws.rs-api</artifactId>
+      <groupId>jakarta.ws.rs</groupId>
+      <artifactId>jakarta.ws.rs-api</artifactId>
       <version>${ws.rs.version}</version>
     </dependency>
     <dependency>
       <groupId>org.springframework</groupId>
       <artifactId>spring-context</artifactId>
       <version>${spring.framework.version}</version>
+      <exclusions>
+        <exclusion>
+          <groupId>org.springframework</groupId>
+          <artifactId>spring-expression</artifactId>
+        </exclusion>
+        <exclusion>
+          <groupId>org.springframework</groupId>
+          <artifactId>spring-core</artifactId>
+        </exclusion>
+      </exclusions>
     </dependency>
     <dependency>
       <groupId>javax.inject</groupId>
       <groupId>org.apache.cxf</groupId>
       <artifactId>cxf-rt-frontend-jaxrs</artifactId>
       <version>${cxf.version}</version>
+      <exclusions>
+        <exclusion>
+          <groupId>org.jboss.spec.javax.rmi</groupId>
+          <artifactId>jboss-rmi-api_1.0_spec</artifactId>
+        </exclusion>
+      </exclusions>
     </dependency>
     <dependency>
       <groupId>org.springframework</groupId>
       <artifactId>spring-web</artifactId>
       <scope>test</scope>
       <version>${spring.framework.version}</version>
+      <exclusions>
+        <exclusion>
+          <groupId>org.springframework</groupId>
+          <artifactId>spring-core</artifactId>
+        </exclusion>
+      </exclusions>
     </dependency>
     <dependency>
       <groupId>org.glassfish.jersey.core</groupId>
       <artifactId>jersey-common</artifactId>
-      <version>${jersey-common.version}</version>
+      <version>${jersey-bom.version}</version>
       <scope>test</scope>
     </dependency>
     <dependency>
       <groupId>org.glassfish.jersey.core</groupId>
       <artifactId>jersey-server</artifactId>
-      <version>${jersey-common.version}</version>
+      <version>${jersey-bom.version}</version>
       <scope>test</scope>
     </dependency>
   </dependencies>